Печатаем ОнЛайн чеки из 1С в Windows и Linux, на ПК и RaspberryPI. Атол, Штрих-М. Из файлов (csv), WebAPI, FTP, Ajax.

Публикация № 872959

Администрирование - Администрирование данных 1С

2
В последнее время появилось множество программ, которые позволяют организовать печать кассовых чеков на ОнЛайн кассах путем выгрузки файла-задания. Но вот беда: все они заточены на работу в ОС Windows... Мы расширяем эти границы и предлагаем печать чеков на любом ФР Атол или Штрих-М в ОС Windows, Linux (Debian, Ubuntu, Mint, RedHat, CentOS), а так же на микро-ПК RaspberryPI!

Программа Кассовый сервер позволяет решить массу задач, связанных с печатью чеков на ОнЛайн кассах:

  • печать на одной кассе с нескольких рабочих мест кассиров
  • работа с несколькими ККМ, подключенными к одному ПК
  • ускорение печати чека из терминальной RDP-сессии
  • организация ультра-бюджетного кассового узла на базе RasbperryPI (не нужны лицензии Windows, Office, антивирусы и лицензии на терминальные подключения (FreeNX)). 

Программа полностью соответствует требованиям ФФД 1.0 и 1.05.
Полностью кроссплатформенная. Имеются готовые сборки для разных ОС.
Универсальное и очень простое API, которое не зависит от ОС или используемой ККМ.
 

Для облегчения изучения API имеется встроенный конструктор запросов. Вводите параметры и выбираете команду - в нижней части экрана пишется строка-команда, которая тут же исполняется на ККМ.

Программа проста в настройке оборудования. Для настройки связи с ККМ имеется конфигуратор


 

Кассовый сервер можно использовать как самостоятельное рабочее место кассира:  имеется встроенное рабочее место кассира, позволяющее пробить любой чек.

 

Касса всегда под контролем. А все операции протоколируются:

 

Так же для действующих и потенциальных клиентов действует техподдержка. Помогаем настроить ККМ, программу. Консультируем по вопросам интеграции...

Пример генерации самого простого чека 1С 7.7
 

Функция глПреобразоватьСтрокуВУТФ8(Стр) Экспорт
    Длина=СтрДлина(Стр);
    Итог="";
    Для Н=1 По Длина Цикл
        Знак=Сред(Стр,Н,1);
        Код=КодСимв(Знак);
        Если Код<128 Тогда
            Итог=Итог+Знак;
        Иначе
            Если (Код>=КодСимв("А"))И(Код<=КодСимв("п")) Тогда
                Итог=Итог+Симв(208)+Симв(144+Код-КодСимв("А"));
            ИначеЕсли (Код>=КодСимв("р"))И(Код<=КодСимв("я")) Тогда
                Итог=Итог+Симв(209)+Симв(128+Код-КодСимв("р"));
            ИначеЕсли (Знак="ё") Тогда
                Итог=Итог+Симв(209)+Симв(145);
            ИначеЕсли (Знак="Ё") Тогда
                Итог=Итог+Симв(208)+Симв(129);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    Возврат Итог;
КонецФункции

Процедура ПечатьККМ()
	Если ЧерезИП=1 Тогда
		АвтоВремяТекущее();
		Записать();
        Ф = СоздатьОбъект("Текст");  
		Если СокрЛП(Автор.login)="GlManager" Тогда
			Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("B;0;ГЛАВНЫЙ_КАССИР;"));
		Иначе
			Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("B;0;"+Автор+";"));
		КонецЕсли;
		ИтогСумма=0;
		ВыбратьСтроки();
		Пока ПолучитьСтроку() = 1 Цикл 
			Если Товар.ВидТовара=Перечисление.ВидыТоваров.Услуга Тогда
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+Товар.Наименование+";"+(Цена*100)+";"+(Количество*1000)+";6;1;0"));
			Иначе
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+Товар.Наименование+";"+(Цена*100)+";"+(Количество*1000)+";6;0;0"));
			КонецЕсли;
			ИтогСумма	= ИтогСумма + Сумма;
        КонецЦикла;
		Если СокрЛП(Контрагент.Наименование)="Клиент пластик" Тогда
			Ф.ДобавитьСтроку("tmde;0;"+(ИтогСумма*100)+";0;0;6;0;0;0");
		Иначе
			Ф.ДобавитьСтроку("tmde;"+(ИтогСумма*100)+";0;0;0;6;0;0;0");
		КонецЕсли;
		Ф.Записать("D:\KKM\check"+НомерДок+".txt");
	КонецЕсли;
КонецПроцедуры 



Пример генерации чека, с указанием ФИО кассира, разбивкой по СНО (УСНО доходы  и ЕНВД), отправкой электрочека на почту или телефон.  1С 7.7

        Ф = СоздатьОбъект("Текст");  
		ИтогСумма=0;
		ДопСумма=0;
		Флаг=0;
		ДопЧек=СоздатьОбъект("Текст");
		ДопЧек.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("B;"+?(ВидОперации = Перечисление.ВидыОперацийЧекККМ.Чек,0,1)+";"+Автор+";"));
		ВыбратьСтроки();
		Пока ПолучитьСтроку() = 1 Цикл 
			Ц=Окр(Сумма/Количество,2,1);
			//Сообщить(Сумма+","+Количество+","+Ц);
			Если Номенклатура.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Услуга Тогда
				Если Флаг=0 Тогда 
					Ф.ДобавитьСтроку("set_tlv;1055;1;2;");  // УСНО Доходы
					Флаг=2;
				ИначеЕсли Флаг=8 Тогда
					Если ДопСумма=0 Тогда ДопЧек.ДобавитьСтроку("set_tlv;1055;1;2;"); КонецЕсли;  // УСНО Доходы
					ДопЧек.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;2;"));
					ДопСумма	= ДопСумма + (Ц*Количество);
					Продолжить;
				КонецЕсли;
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;2;"));
			Иначе
				Если Флаг=0 Тогда 
					Ф.ДобавитьСтроку("set_tlv;1055;1;8;");  // ЕНВД
					Флаг=8;
				ИначеЕсли Флаг=2 Тогда
					Если ДопСумма=0 Тогда ДопЧек.ДобавитьСтроку("set_tlv;1055;1;8;"); КонецЕсли;  // ЕНВД
					ДопЧек.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;1;"));
					ДопСумма	= ДопСумма + (Ц*Количество);
					Продолжить;
				КонецЕсли;
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;1;"));
			КонецЕсли;
			ИтогСумма	= ИтогСумма + (Ц*Количество);
		КонецЦикла;

		Если ПустоеЗначение(Контрагент)=0 Тогда
			Д="";
			Если Контрагент.ОтправкаЧека=Перечисление.ОтправкаЧека.ТелефоныФизЛица Тогда
				Д=СокрЛП(Контрагент.ЮрФизЛицо.Телефоны);
			ИначеЕсли Контрагент.ОтправкаЧека=Перечисление.ОтправкаЧека.ЭлПочта Тогда
			    Д=СокрЛП(Контрагент.ЭлПочта);
			КонецЕсли;
		КонецЕсли;
		Если ПустоеЗначение(Д)=0 Тогда 
			Ф.ДобавитьСтроку("set_tlv;1008;5;"+Д+";");
		КонецЕсли;
		
		Если ПлатежнаяКарта=1 Тогда
			Ф.ДобавитьСтроку("tmde;0;"+(ИтогСумма*100)+";0;0;6;0;0;0;");
		Иначе
			Ф.ДобавитьСтроку("tmde;"+(Макс(Получено,ИтогСумма)*100)+";0;0;0;6;0;0;0;");
		КонецЕсли;
		Ф.Записать("C:\RndItSoft\Checks\"+НомерДок+".txt");
		
		Если ДопСумма>0 Тогда
			Если ПустоеЗначение(Д)=0 Тогда 
				ДопЧек.ДобавитьСтроку("set_tlv;1008;5;"+Д+";");
			КонецЕсли;
			
			Если ПлатежнаяКарта=1 Тогда
				ДопЧек.ДобавитьСтроку("tmde;0;"+(ДопСумма*100)+";0;0;6;0;0;0;");
			Иначе
				ДопЧек.ДобавитьСтроку("tmde;"+(Макс(Получено-ИтогСумма,ДопСумма)*100)+";0;0;0;6;0;0;0;");
			КонецЕсли;
			ДопЧек.Записать("C:\RndItSoft\Checks\"+НомерДок+"_2.txt");
			
        КонецЕсли;

Работа с Кассовым сервером из Web-приложения.  Печать чека из PHP
 

/**
 * Class Sale
 */
class Sale{

    /**
     * Печать чека
     * @param int $id id из sale
     */
    static function CheckKKM($id=0){

        $buf="B;".(isset($_REQUEST['returnsale'])?"1":"0").";".(User::comment()?User::comment():"Колесников Д.Г.").";\n";
        $add_summ=$summ=0;
        if(!($sale=DB::Select("sale",($id>0?"id=".intval($id):"user='".$_SESSION['user']['id']."' ORDER by time DESC"))) )fb_err("Нет доступной операции для печати чека!");
        // todo нельзя пробить чек на несегодняшнюю продажу
        $id=$sale['id'];
        $add_chek='';
        $flag=0;
        // $sale['visa'] - эта часть оплачена платиком, остальное наличными
        $query=DB::sql("SELECT * FROM `".self::db_prefix."sale2` WHERE sale='".$id."'");
        while(($data = DB::fetch_assoc($query))){
            $tovar=Tovar::GetTovar($data['tovar'],1); if(!$tovar)fb_err("Нет товара № ".$data['tovar']);
            if($tovar['type']==TYPE_TOVAR){
                if($flag==0){  $buf .= "set_tlv;1055;1;8;\n";  $flag=8; } // ЕНВД
                elseif($flag!=8){
                    $add_chek.= "SMDE;" .$tovar['name'].";".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;0;\n";
                    $add_summ+=$data['summ'];
                    continue;
                }
                $buf .= "SMDE;" .$tovar['name'].";".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;0;\n";
            }else{
                if($flag==0){  $buf .= "set_tlv;1055;1;2;\n"; $flag=2; } // УСНО Доходы
                elseif($flag!=2){
                    $add_chek.= "SMDE;" .$tovar['name'].";".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;1;\n";
                    $add_summ+=$data['summ'];
                    continue;
                }
                $buf .= "SMDE;Загар в солярии;".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;1;\n";
            }
            $summ+=$data['summ'];
        }
        if($summ>0){
            $sale_visa=min($sale['visa'],$summ);
            $buf.="tmde;".(($summ-$sale_visa)*100).";".($sale_visa*100).";0;0;6;0;0;0;"/*.";\n"*/;
            // если сегодня это первый чек, открыть смену
            if(!DB::Select("sale","`services`&2 and time>='".date("Y-m-d")."'")){
                $buf="open_session;\n".$buf;
            }
            self::CmdKKM($buf,$id);
            DB::sql("UPDATE `" . db_prefix . "sale` SET `services`=`services`|".(isset($_REQUEST['returnsale'])?"4":"2")." WHERE id=" . $id);
            if($add_summ>0){ // второй чек по другой СНО
                $buf="B;".(isset($_REQUEST['returnsale'])?"1":"0").";".(User::comment()?User::comment():"Колесников Д.Г.").";\n".
                    "set_tlv;1055;1;".($flag==8?2:8).";\n" . $add_chek;
                $sale_visa=min($sale['visa'],$summ);
                $buf.="tmde;".(($summ-$sale_visa)*100).";".($sale_visa*100).";0;0;6;0;0;0;"/*.";\n"*/;
                self::CmdKKM($buf,$id.'_2');
            }
        }
    }


    /**
     * Отправить команду в KKM
     * @param string $format =
     *  open_session;
     *  X;
     *  Z;
     *  g; анулировать последний открытый чек
     */
    static function CmdKKM($format='x',$id='')
    {
        $format.=";\n";
        file_put_contents('C:\RndItSoft\Checks\chek'.$id.'.txt', Convert::win2utf($format));
        file_put_contents($_SERVER['DOCUMENT_ROOT'].'/log/chek.log', $format."\n\n", FILE_APPEND);
    }

}

 

Причины купить

Решение актуальных проблем с печатью чеков, в том числе из старых конфигураций и проблемных RDP-сессий.
Полное соответствие ФФД 1.0 1.05 и большей части 1.1
Возможность получить результат исполнения команды (например, фискальный признак или фискальный номер документа).
Возможность организовать работу с одной ККМ разных кассиров (даже территориально в разных офисах).
Возможность отключить печать чека (только электрочек).
 

Достоинства

Единственный кассовый сервер, работающий в разных операционных системах и предоставляющий такой широкий набор функций.

Простота интеграции и предсказуемость результата работы.

Встроенный анализатор нештатных ситуаций.

Возможность адаптации ПО под требования заказчика (отдельная опция).

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

2

Скачать файлы

Наименование Файл Версия Размер
Руководство по установке и настройке.
.pdf 1,46Mb
23.07.18
22
.pdf 1,46Mb 22 Скачать бесплатно
Руководство программиста: описание API (FileAPI, AjaxAPI, WebAPI)
.pdf 1 003,49Kb
23.07.18
13
.pdf 1 003,49Kb 13 Скачать бесплатно
26.07.2018
5.18.07.04 0 1300 руб.

Моментальная
доставка

26.07.2018
5.18.06.20 0 1300 руб.

Моментальная
доставка

26.07.2018
5.18.07.04 0 1300 руб.

Моментальная
доставка

26.07.2018
0 500 руб.


Новый вопрос

E-mail*

Специальные предложения

См. также

Множественный поиск текста в обработках и конфигурациях 2

Инструменты и обработки no Приложение (exe) Россия Windows Платные (руб) Поиск данных

Приложение быстро ищет сразу несколько слов и показывает, в каком контексте они используются, без установленной 1С.

1000 руб.

13.11.2019    492    11    0       

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет 4

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Платные (руб) Банковские операции Кассовые операции Обработка документов

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая). Принимаются пожелания пользователей на доработку данного функционала (писать в комментариях).

3000 руб.

24.09.2019    2354    6       

Создание документов "Реализация товаров и услуг" и "Приобретение товаров и услуг" на заданную сумму с учетом остатков в конфигурациях "УТ 11.4", "1С:КА 2.4" и "1С:ERP УП 2.4" (расширение конфигурации) 2

Инструменты и обработки Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ УТ11 Россия БУ УУ Оптовая торговля Учет ТМЦ Платные (руб) Обработка документов

В расширении "Создание документов "Реализация товаров и услуг" и "Приобретение товаров и услуг" на заданную сумму с учетом остатков в конфигурациях "УТ 11.4", "1С:КА 2.4" и "1С:ERP УП 2.4"" реализован дополнительный функционал по созданию документов "Реализация товаров и услуг " и "Приобретение товаров и услуг" на заданную сумму с учетом остатков без снятия конфигурации с поддержки фирмой 1с

4000 руб.

05.09.2019    3137    0       

Мониторинг баз и серверов 1С 22

Инструменты и обработки Системный администратор Конфигурация (md, cf) v8 Windows Платные (руб) Журнал регистрации Статистика базы данных Производительность и оптимизация (HighLoad)

В сферу обязанностей при работе с клиентами входит контроль работы баз данных и серверов 1С. Нужно понимать что происходит в базах, есть ли ошибки, зависания у пользователей и фоновых задач, блокировки или какое-то необычное поведение системы, получение информации о причинах возникновения проблем и их оперативное устранение и т.д. В качестве источников информации использую консоль кластеров 1С, технологический журнал 1С, журналы регистрации базы 1С. Для автоматизации части операций мониторинга и анализа создал инструмент на основе 1С.

7500 руб.

28.08.2019    3129    26    2       

AddinInfo: информация о внешней компоненте 1С 7

Инструменты и обработки Программист Приложение (exe) Windows Платные (руб) Сервисные утилиты Разработка внешних компонент

Программа позволяет получить информацию о свойствах и методах внешней компоненты 1С.

5000 руб.

20.08.2019    1523    0       

Массовое перемещение товаров на складах. УТ 11.4 4

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::ОУ УТ11 УУ Учет ТМЦ Платные (руб) Обработка документов

Если Вы устали тратить бесчисленное количество времени на перемещение товаров между складами, то эта разработка для Вас! Она позволяет увидеть необходимую информацию о наличии остатков на различных складах, продажах за период, ценах, а также создавать массовые перемещения нажатием одной кнопки!

1500 руб.

29.07.2019    2965    2    2       

Программа групповой печати чеков ККМ Атол и Штрих из текстового файла, поддержка 54-ФЗ от 01.07.19 7

Инструменты и обработки Бухгалтер Пользователь Архив с данными Россия БУ Windows Кассовые операции Платные (руб) Пакетная печать ККМ

Предназначена для групповой печати чеков. Что печатать в теле чека описано в текстовом файле с разделителем запятая (CSV) Подходит для любого языка программирования который умеет записывать в текстовый файл

1000 руб.

26.07.2019    2894    0       

[ЕХТ] Автоматическая установка времени документов по произвольным правилам 5

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 v8::УФ 1cv8.cf Платные (руб) Обработка документов

В конфигурациях, где время документов является одним из ключевых факторов правильного отражения документов в учете, данное решение позволяет настроить автоматическую установку нужного времени для любых документов по произвольным правилам.

2000 руб.

24.07.2019    2619    2       

Тип контрагента для БГУ 1 и БГУ2 4

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Платные (руб) Обработка справочников

Обработка предназначена для анализа текущего типа контрагента на соответствие типу контрагента по наименованию и банковскому/казначейскому счету. Есть возможность установить необходимый тип контрагентам. Анализ можно проводить как по всем контрагентам, так и только по тем, у кого есть обороты за указанный период.

3000 руб.

19.06.2019    2795    0       

Шаблоны медицинских документов (ШМД) для 1С: Медицина поликлиника 3

Отчеты и формы Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Здравоохранение, медицина, стоматология УУ Платные (руб) Обработка документов

Обработка предназначена для работы с отраслевым решением "1С: Медицина поликлиника 2.1.4.1". Может быть использована медицинскими организациями в работе врачебного участка при заполнении протокола операции (осмотра пациента) с помощью специально разработанного шаблона медицинского документа.Основана на использовании стандартов медицинской помощи для диагнозов классификатора МКБ10.

1000 руб.

04.04.2019    3908    0       

Как свернуть базу УТ 10.3 28

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия УУ Платные (руб) Свертка базы

Как свернуть УТ 10.3. Цель свертки - свернуть остатки по товарам и по взаиморасчетам с контрагентами.

1500 руб.

04.04.2019    6291    25    4       

Быстрый ввод документов в "1С:Бухгалтерия 3.0" 2

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 БУ Оптовая торговля Производство готовой продукции (работ, услуг) Платные (руб) Обработка документов

Хотите экономить время на операциях ввода однотипных документов? Дополнительная обработка для "1С:Бухгалтерия 3.0" позволит Вам экономить время на создании документов - счет на оплату, реализация товаров услуг, счет-фактура выданный. Групповое создание документов выполняется на основании информации в договорах контрагентов. Обработка группового создания документов подходит для обслуживающих и сервисных компаний таких как - охранные предприятия, службы доставки, бухгалтерское обслуживание, усулуги телекоммуникаций, юридические услуг и т.д. Практика показывает, что время работы сокращается от нескольких дней, до 30 минут.

3000 руб.

24.03.2019    4086    5       

Автоматическое формирование и отправка счетов, актов и счетов-фактур для БП 3.0 6

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 БУ Документооборот и делопроизводство Платные (руб) Обработка документов Email

Данная обработка позволяет сократить объем ручных операций, выполняемых ежемесячно бухгалтером или его помощником за счет автоматизации систематического процесса.

5000 руб.

12.02.2019    4670    2       

Версионирование регистров сведений (необъектных данных) - история изменений по версиям записей регистров сведений - ВНОД 11

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 v8::УФ 1cv8.cf Windows Платные (руб) Сервисные утилиты Журнал регистрации

ВНОД – отдельная (дополнительная) подсистема, которая построена на основе типовой подсистемы «Версионирование объектов». Предназначена для сохранения и анализа изменений независимых (периодических и непериодических) регистров сведений, с точностью до состава измерений, ресурсов и реквизитов записей.

1800 руб.

11.02.2019    5095    2    14       

Универсальная обработка удаления данных 5

Инструменты и обработки Программист Архив с данными v7.7 v8 1cv8.cf 1cv7.md Россия Платные (руб) Универсальные обработки Чистка базы

Универсальная обработка удаления как помеченных, так и не помеченных объектов конфигураций 1С 7.7, 8.2, 8.3.

1000 руб.

05.02.2019    4476    0       

Универсальная обработка для получения и прикрепления подписанных электронных документов к документам 1С через API Диадок и СБИС + отчет по не подписанным электронным документам 15

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 БП3.0 УХ Россия БУ Документооборот и делопроизводство Платные (руб) Обработка документов Внешние источники данных

Функционал обработки - получение файлов подписанных с двух сторон электронных документов за выбранный период в формате .pdf и прикрепление их к соответствующим документам в 1С; поиск не сопоставленных электронных документов за период и автоматическое сопоставление их с соответствующими документами в 1С; отчет по не подписанным электронным документам за период с отправкой на почту и функцией перехода из отчета в документ на сайте Диадок/СБИС и 1С.

5000 руб.

17.12.2018    7127    9       

Оприходование отрицательных остатков для 1С:Бухгалтерии 3.0 11

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Учет ТМЦ Платные (руб) Обработка документов

Находит отрицательные остатки за выбранный период и позволяет оприходовать их двумя типами документов.

1000 руб.

17.12.2018    4355    3    2       

Не регламентное задание обмена данными с Офлайн оборудованием 2

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Розница Россия Розничная торговля Платные (руб) Внешние источники данных ККМ Весы

Автоматический обмен с офлайн оборудованием. Позволяет выгружать номенклатуру в кассы ККМ , весы с печатью этикеток, а так же загружать отчет о розничных продажах из касс ККМ. Обработка запускает стандартный механизм обмена через заданный пользователем интервал времени.

1000 руб.

14.12.2018    4740    0       

Расширение для добавления средних и нормативных начислений к приборам учета, для программы 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК 3.0 3

Инструменты и обработки Бухгалтер Расширение (cfe) v8::УФ 1cv8.cf Энергетика и ЖКХ Россия УУ Платные (руб) Обработка документов

При при отсутствии переданных показаний необходимо проводить начисление по норме или по среднему. В конфигурации такие начисления рассчитываются на лицевой счет, и не добавляются к показаниям счетчиков. В дальнейшем при передаче показаний эти начисления сторнируются. Возникла необходимость средние и нормативные показания прибавлять к приборам учета, для этого было разработано это расширение.

1000 руб.

12.12.2018    3158    0       

Загрузка из файла приборов учета (счетчиков) с вводом начальных показаний в программу 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК 16

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Энергетика и ЖКХ Россия БУ Windows Платные (руб) Обработка документов Загрузка и выгрузка в Excel

Внешняя обработка для массовой загрузки приборов учета (счетчиков) из файла Excel в программу 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК редакции 3.0. Платформа - 1С Предприятие 8.3 (управляемая форма) Конфигурация - 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК редакции 3.0 (Тиражные решения 1С Рарус) Тестировалось на платформе версии 8.3.13.1513, конфигурации версии 3.0.65, 3.0.70.5, 3.0.70.10. Обработка позволяет загрузить из файла Excel приборы учета (счетчики) по выбранным услугам ЖКХ с вводом начальных показаний с привязкой по помещениям или лицевым счетам.

1000 руб.

04.12.2018    6775    1       

Вес, объем, площадь и длина в заказе и реализации для УТ11, ERP, КА 7

Отчеты и формы Бухгалтер Расширение (cfe) v8::ОУ ERP2 УТ11 КА2 Оптовая торговля, дистрибуция, логистика Россия УУ Оптовая торговля Платные (руб) Обработка документов

Если необходимо видеть вес, объем, длину, площадь по каждой строке заказа (реализации). Это может быть важно при торговле строительными материалами.

3000 руб.

29.11.2018    5160    2       

Автоматическое пакетное создание актов и счетов для клиентов на абонентской системе оплаты 6

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Производство готовой продукции (работ, услуг) Платные (руб) Обработка документов

Обработка позволяет автоматически генерировать ежемесячные счета и акты для клиентов на абонентке. Реализованы функции: Выставляется несколько услуг Рассчитывается и выставляется пеня Пакетная печать документов Пакетная отправка печатных форм по электронной почте Тестирование проводилось на актуальном релизе 1С:Бухгалтерия 8 версии 3.0.66.53

3950 руб.

21.11.2018    4339    0       

Обмен с ФГИС Меркурий (Ветис.API) для всех* конфигураций 1С 7.7 49

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v77::ОУ v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ТиС 1С7:УСН Сельское хозяйство и рыболовство Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Пищевая промышленность Россия БУ УУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Платные (руб) Обработка документов Внешние источники данных

Полностью автоматизированный обмен между конфигурациями 1С 7.7 и ФГИС Меркурий через Ветис.API для всех видов деятельности (Опт, Розница, Производство). Для организации обмена с ФГИС Меркурий требуется минимальная доработка конфигураций (поддерживается "из коробки" 1С: "Торговля и склад ред. 9.2", 1С: "Комплексная ред. 4.5", 1С: "Бухгалтерия 7.7", 1С: "УСН 7.7", 1С Предприниматель, другие конфигурации по заказу, включая нетиповые и самописные). Модуль разработан таким образом, чтобы минимизировать затраты по внедрению в произвольную конфигурацию на базе 1С 7.7. Работа программного решения осуществляется без доработки типовых объектов конфигурации - добавляются новые справочники, документы и пр. без изменения существующих объектов метаданных. Это позволяет поддерживать и легко обновлять даже нетиповые конфигурации. * Благодаря продуманной архитектуре возможно внедрить программный продукт для произвольной конфигурации 1С 7.7. (включая нетиповые и самописные) в кратчайшие сроки на предприятии пользователя и начать обмен документами с отправителями и получателями подконтрольной продукции. Вы можете прямо сейчас БЕСПЛАТНО скачать демо-версию без ограничения по функционалу и опробовать решение в полном объеме перед покупкой. В данном программном продукте реализованы все технические требования Россельхознадзора по обмену в формате 2.0 и 2.1. Решение прошло опытную эксплуатацию и тестирование на крупных объектах всех видов деятельности: Производство, Опт, Розница.

3000 руб.

21.11.2018    13393    371    39       

Создание документов "Реализация (акты, накладные)" и "Поступление (акты, накладные)" в "1с8 Бухгалтерия предприятия, редакция 3.0" на заданную сумму с учетом остатков (Расширение версии 2019-2) 6

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::БУ БП3.0 БУ Оптовая торговля Платные (руб) Обработка документов

В расширении для конфигурации "Бухгалтерия предприятия, редакция 3.0" реализован дополнительный функционал по созданию документов "Реализация (акты, накладные)" и "Поступление (акты, накладные)" на заданную сумму с учетом остатков без снятия ее с поддержки фирмой 1с.

3000 руб.

14.11.2018    5197    0       

Массовое открытие лицевых счетов в программе 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК 56

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Энергетика и ЖКХ Россия БУ Windows Дебиторская и кредиторская задолженность Платные (руб) Обработка справочников Загрузка и выгрузка в Excel

Внешняя обработка для массового создания из файла Excel помещений в зданиях с открытием по ним лицевых счетов и привязкой к физ.лицам, контрагентам, жильцам в программе 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК редакции 3.0.

1000 руб.

13.11.2018    10088    37       

Бухгалтерия 3.0. Открытие проведенных документов только на чтение 3

Инструменты и обработки Системный администратор Бухгалтер Архив с данными v8::БУ БП3.0 Россия БУ Платные (руб) Обработка документов

Если Вы являетесь главных бухгалтером, то скорее всего сталкивались с тем, что постоянно приходится перезакрывать месяца из-за того, что кто-то из сотрудников (а может и Вы сами) перепровели документ, даже ничего в нем не изменив. Другими словами - "просто посмотрели". Просто закрыли документ не крестиком, а красивой желтой кнопкой "Провести и закрыть". Да, в 1С есть штатная возможность установки дат запрета, но, во-первых, не все её используют, а во-вторых, как правило закрывают уже старые периоды, чтобы не сломать отчетность. Т.е. текущие документы все также можно открыть и перепровести. Для предупреждения данных ситуаций и предназначено данное расширение. Оно проверяет - проведен ли документ и если он проведен - открывает документ только на чтение. Требуется внести в документ изменение - отмените проведение и затем уже изменяйте.

1000 руб.

06.11.2018    3398    5       

Предупреждение об отсутствии работников при выплате аванса фиксированной суммой. ЗУП 3, ЗКГУ 3 47

Отчеты и формы Бухгалтер Расширение (cfe) v8::СПР v8::УФ ЗУП3.x Россия БУ Зарплата Платные (руб) Обработка документов

Если Вы используете 1С: ЗУП 3.1 или 1С: ЗКГУ 3.1 и производите выплату аванса фиксированной суммой или процентом от тарифа, то, вероятно, сталкивались с тем, что программа при заполнении документа добавляет в список сотрудников, которые в период с 1-ого по 15-ое число месяца были в отпуске, на больничном и т.п. При допуске подобных недочетов в дальнейшем проблемы начинают нарастать: сотрудник по итогам месяца остается должен организации, что влечет за собой неудержание НДФЛ, что, в свою очередь, ведет к проблемам при подготовке отчета 6-НДФЛ. Данное расширение добавляет в документы выплаты заработной платы новый функционал, который производит проверку сотрудников, попавших в документ выплаты аванса на предмет отсутствия на рабочем месте (в отпуске, в декрете, на больничном, прогулы и т.д.) и выдаче соответствующих предупреждений. В результате Вы можете проанализировать - стоит ли выдавать сотруднику полновесный аванс, уменьшить ли сумму аванса или отказаться от выплаты аванса вовсе.

1000 руб.

25.10.2018    8729    2       

Автоматический расчет страхового стажа для оплаты больничных листов. ЗУП 3, ЗКГУ 3, КА 2, ERP 2 7

Инструменты и обработки Бухгалтер Архив с данными v8::СПР v8::УФ ЗУП3.x Россия БУ Зарплата Платные (руб) Обработка справочников

Расчет стажа для оплаты больничных листов является достаточно трудоемким процессом, особенно при приеме на работу сотрудников с обширным трудовым опытом. При этом в программу вводятся данные о прежних местах работы сотрудника, однако автоматического расчета стажа в типовой конфигурации не предусмотрено, хотя данные для этого введены. Предлагаемое расширение позволяет произвести автоматический расчет страхового стажа для оплаты больничных листов на основании введенных данных о прежних местах работы. Расчет производится согласно Приказу Минздравсоцразвития России от 06.02.2007 N 91 (ред. от 15.11.2016) "Об утверждении Правил подсчета и подтверждения страхового стажа для определения размеров пособий по временной нетрудоспособности, по беременности и родам" (Зарегистрировано в Минюсте России 14.03.2007 N 9103).

1000 руб.

25.10.2018    5147    4       

Загрузка из Excel по шаблонам 19

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 БП3.0 УТ11 Россия Windows Платные (руб) Обработка документов Загрузка и выгрузка в Excel

Универсальная обработка по формированию документов на основании табличных данных (Excel и т.п.). Использует метод создания документов на основании шаблонов, то есть документов уже созданных в базе ранее. Пользователю нужно только в настройках колонок определить какие реквизиты документа, созданного на основании шаблона будут заменены на данные из входящей таблицы.

1500 руб.

19.10.2018    6705    26    4       

Выравнивание и анализ остатков ЕГАИС (Далион, Трактир) 7

Отчеты и формы Бухгалтер Архив с данными v8 1cv8.cf Россия БУ Windows Розничная торговля Учет ТМЦ Акцизы Платные (руб) Анализ учета Обработка документов

Отчёт показывает остатки алкоголя на складе учетной программы и в регистрах ЕГАИС в декалитрах по каждой номенклатурной позиции. Если сопоставление множественное (одна номенклатура - много ЕГАИС номенклатуры, или много номенклатуры - одна ЕГАИС номенклатура), то отчет производит корректное распределение количеств. На основании этого отчёта можно создать документы в ЕГАИС, с помощью которых можно выравнять остатки. Даже пересорт в разрезе кодов и объемов.

1500 руб.

12.10.2018    6217    4       

Загрузка курсов валют НБРБ (обычная и управляемая форма) 4

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Беларусь БУ Банковские операции Платные (руб) Обработка справочников WEB

Загрузка курсов валют с сайта НБРБ (Национального банка Республики Беларусь) версия 2.0 на обычных и управляемых формах по API. Не требует подписки на ИТС!

2000 руб.

08.10.2018    6321    0       

Просмотр файлов журнала регистрации 1С (*.lgd) 1

Отчеты и формы Системный администратор Архив с данными v8 1cv8.cf Windows Платные (руб) Журнал регистрации

Программа для просмотра больших файлов журнала регистрации 1С в формате *.lgd. За счет отбора по виду события или неявного представления, позволяет работать с файлам большого размера.

2000 руб.

28.09.2018    6053    3       

1С:Корпоративный инструментальный пакет 8 (1С:КИП). 0

ПО Системный администратор Программист Приложение (exe) v8 1cv8.cf Россия Windows Платные (руб) Администрирование данных 1С

«1С:Корпоративный инструментальный пакет 8» (1С:КИП) предназначен для повышения производительности, масштабируемости и надежности информационных систем, работающих на платформе «1С:Предприятие 8» за счет решения широкого круга технических задач, возникающих на всех этапах жизненного цикла информационной системы.

100800 руб.

09.09.2018    1289    0       

Печать кассовых чеков на одну ККМ с нескольких рабочих мест для УТ 11.4, КА 2.4, Розница 2.2, УНФ 1.6, БП 3 ( 54-ФЗ, Управляемые формы ) 216

Инструменты и обработки Бухгалтер Пользователь Расширение (cfe) v8::БУ v8::ОУ v8::УФ Розница УНФ БП3.0 УТ11 КА2 Кассовые операции Розничная торговля Платные (руб) ККМ Фискальный регистратор

Расширение конфигурации для УТ 11.4, КА 2.4, Розница 2.2, УНФ 1.6, БП 3 (Управляемые формы) позволяет выполнять печать кассовых чеков на одну ККМ 54-ФЗ с нескольких рабочих мест. НИКАКИХ НАСТРОЕК В РАЗРАБОТКЕ - ПОДКЛЮЧИЛ И ПЕЧАТАЙ. Если у вас несколько отделов и одна ккм - печатайте на одну ккм! Если у вас две ккм и одна поломалась - печатайте на одну ккм, пока ремонтируете другую!

1000 руб.

27.08.2018    22221    377    123       

QR - штрихкодирование документов БЕЗ изменения печатных форм и конфигурации, с произвольными алгоритмами создания QR -кода и обработки для УТ 11 (все), ERP 2, КА 2, УТ 10.3, Розница 2.2, УНФ 1.6, БП 3 31

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 УТ10 Розница УНФ ERP2 БП3.0 УТ11 КА2 УУ Платные (руб) Обработка документов Поиск данных Сканер штрих-кода

Все знают, что в QR - код можно закодировать большое количество информации, но не все знают что это можно использовать в автоматизации бизнеса, в частности в плане документооборота. Представьте, что есть система, которая НЕ ТРЕБУЕТ изменения конфигурации, НЕ ТРЕБУЕТ изменения ни одной печатной формы для добавления QR-кода, включая внешние, НЕ ХРАНИТ данные штрихкодов и их связь, от чего база не "пухнет", ИМЕЕТ возможность закодировать в QR-коде произвольные данные параметров для последующей обработки полученных данных, УМЕЕТ обработать считанный QR-код как ВЫ захотите - например, ОТКРЫТЬ документ, СОЗДАТЬ документ любого вида по входным параметрам, ОТОБРАТЬ из документа определенные данные и перенести их в другой документ, ОТКРЫТЬ отобранные данные по данным QR-кода в виде таблицы для сверки данных и прочее. А так же ИМЕЕТ удобный интерфейс, ХРАНИТ историю операций в обход базы для каждого пользователя в отдельности и УМЕЕТ работать с 2D - сканерами в режиме клавиатуры и эмуляции USB COM. А так же автоматически распознавать отсканированные печатные формы и выполнять заданные произвольные алгоритмы! (Обновление от 16.01.2019, версия 2.00)

5990 руб.

26.08.2018    12441    71    2       

Управление последовательностями проведения документов по измерениям (УФ) 4

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ БП3.0 УТ11 Платные (руб) Обработка документов

В процессе работы  возникла необходимость управления последовательностями в разрезе измерений. Штатные возможности не позволяют этого сделать. Но бывает очень необходимо восстановить последовательность только по одному измерению (например, подразделению, организации и т.д.).

1000 руб.

24.08.2018    4869    0       

Автоматическое формирование документов (БП 3.0, УНФ) 5

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 УНФ БП3.0 Россия БУ Платные (руб) Обработка документов

Внешняя обработка для формирования и рассылки документов (Счет на оплату, Реализация, Счет-фактура) по шаблону с возможностью выполнения по расписанию.

3000 руб.

10.08.2018    6562    2       

Две или более касс РМК Розница 2.2. ИНН покупателя РМК. 98

Инструменты и обработки Системный администратор Архив с данными v8 Розница Россия Кассовые операции Розничная торговля Ценообразование, анализ цен Платные (руб) ККМ

Часто задаваемый вопрос, можно ли в 1С:Розница подключить несколько касс к на одно рабочее место?! Теперь можно. Обработка позволяет подключать не ограниченное количество касс на одно рабочее место, и выбирать, когда на какой кассе пробивать чек, не всегда, только когда это не обходимо. Публикация состоит из двух файлов, можно подключить расширение конфигурации для ПРОФ версии. Для базовой версии внешняя обработка РМК.

2000 руб.

07.08.2018    18180    72       

1С Печать пакета документов по шаблонам MS Word 9

Инструменты и обработки Программист Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 1cv8.cf Платные (руб) Обработка документов Пакетная печать

Универсальный инструмент, позволяющий формировать не только отдельные печатные формы на основе шаблонов Word и данных информационной базы, но и пакеты документов. Для каждого документа в 1С можно настроить (1 раз) и печатать свои наборы печатных форм (пакетов).

5000 руб.

27.07.2018    11171    0       

Удобная инвентаризация алкоголя для конфигурации Розница 2.2 32

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Розничная торговля Учет ТМЦ Акцизы Платные (руб) Обработка документов

В розничных точках периодически возникает необходимость проводить инвентаризацию алкоголя с целью приведения остатков алкогольной продукции в соответствие c остатками ЕГАИС и наоборот. Пользоваться типовыми инструментами не всегда удобно, так как некоторые действия избыточны для наших целей. Данная обработка предназначена для того, чтобы упростить работу товароведа при пересчёте алкоголя. Адаптировано под релиз 2.2.9. Кроме того, не всегда удобно использовать только типовой функционал конфигурации Розница 2.2 для выполнения операций по учету алкогольной продукции.

5000 руб.

19.07.2018    11280    14    27       

Функциональные списки номенклатуры и характеристик [УТ 11, КА 2, ERP] 51

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ v8::УФ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) УУ Кассовые операции Комиссионная торговля Оптовая торговля Розничная торговля Ценообразование, анализ цен Платные (руб) Обработка справочников Ценообразование, прайсы Рабочее место Работа с интерфейсом Ценники

Расширение для форм списков и выбора номенклатуры и характеристик для УТ 11, КА 2, ERP 2. Превращает форму списка в полноценный инструмент по управлению каталогом товаров. Позволяет быстро наполнять каталог картинками, устанавливать цены по списку номенклатуры, контролировать и просматривать присоединенные изображения. Добавляет возможность просмотра цен и остатков для форм списков и выбора номенклатуры и характеристик с отборами.

3000 руб.

06.07.2018    13424    33    34       

Онлайн-кассы (54-ФЗ). Печать чека ККМ из Реализации товаров и услуг в УТ 10.3 15

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Кассовые операции Розничная торговля Платные (руб) ККМ Фискальный регистратор

Онлайн-кассы (54-ФЗ). Печать чека ККМ с номенклатурой из Реализации товаров и услуг (РТиУ). УТ 10.3. (Протестировано на платформе 8.2.19.130, релиз 10.3.47.3., а также на платформе 8.3.14 на релизе 10.3.54.3) 

1000 руб.

03.07.2018    11447    2       

Расчёт планового аванса пропорционально отработанному времени для ЗУП 3.1 10

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x Россия БУ Windows Зарплата Платные (руб) Обработка документов

Обработка используется в типовой конфигурации Зарплата и Управление Персоналом, редакция 3. Применяется для корректировки выплаты планового аванса, начисленного сотруднику согласно отработанному времени.

2000 руб.

29.06.2018    8236    0